CWT Community V2.1.1 released

I have released a new bugfix version of the Community. Here is the detailed list of changes:

  • Bugfix: Sending the notification e-mails failed under certain circumstances.
  • Improvement: Added hook to the PROFILE_VIEW.
  • Improvement: Added XCLASS extension points to all classes.
  • Bugfix: Misc. improvements and minor fixes.
  • Bugfix: BE module works with Typo3 4.6.x and greater from now on.
  • Bugfix: Issue with incompatible “fromName” for the notification e-mails solved.
  • Bugfix: Replaced all dots (“.”) in locallang values with underscores (“_”). See bug #8657 in T3Forge (http://forge.typo3.org/issues/8657).

Regards,
Sebastian

7 thoughts on “CWT Community V2.1.1 released

  1. Hallo Sebastian,

    Ich glaube ich habe einen Bug in the CWT-Extension gefunden. Man kann beim Klick auf “Album bearbeiten” (Gallerie-extension d. CWT) unter anderem die Zugriffsberechtigung einstellen, was auch ohne weiteres geht. Klickt man “Album bearbeiten” erneut, werden im Formular bei Titel und Beschreibung schon mal angezeigt, was man vorhin abspeichert hat. Allerdings nicht bei der Zugriffsberechtigung. Egal was man einstellt, es wird immer “Für alle sichtbar” angezeight obwohl in der Tabelle “tx_cwtcommunity_albums” sich der Wert beim Feld “access_policy” geändert hat. Man bekommt den Eindruck, daß dieser Wert nicht veränderbar ist, wenn man nicht weiß, wo man nachschauen muss in der Datenbank. Manche werden denken, daß die Bilder im Album immer für alle sichtbar sein müssen.
    Wie kann man den Bug beheben?

    Grüße
    Roger

  2. Hallo Sebastian,

    ich habe einen Verbesserungsvorschlag für die nächste Version. Gemäß Datenschutzgesetz muß z.B. einem Verein die freiwillige Einwilligung der Mitglieder vorliegen, wenn er deren Daten im Netz veröffentlichen will (egal, ob die Seite dann mit Paßwort geschützt ist oder nicht). Dabei kann jedes dieser Mitglieder selber entscheiden, WELCHE Daten veröffentlicht werden. Das bedeutet, daß der z.B. bei Profilsichtbarkeit “Für alle sichtbar” Adresse und E-Mail zustimmt, der andere aber nur Adresse anzeigen lassen will.

    Momentan läßt sich, wenn ich das richtig sehe, über die Profilsichtbarkeit nur ein pauschaler Bereich steuern, aber nicht einzelne Daten.

    Ich weiß natürlich nicht, wie aufwändig so etwas ist, wäre aber auf jeden Fall eine praxisnahe und sinnvolle Erweiterung Deiner tollen Extension.

    Gruß,
    Katharina

  3. Hi Sebastian,

    habe Deine Extension soweit ohne Probleme einrichten können.
    Jedoch habe ich ein kleines Problem mit der Buddylist.
    Ich werde nach einer Freundschaftsanfrage auf den Buddyadmin weitergeleitet. Komischerweise erscheint der entsprechende Nutzer nicht in den ausgegangenen Freundesanfragen.
    Hast Du einen Tipp wo ich nachschauen muss um dieses Problem zu beheben?
    Die PIDs habe ich nach der Doku eingerichtet.

    Desweiteren habe ich einen Misch aus deutschen und englischen Labels.
    So ist z.B. die das Formular zur Profilbearbeitung auf Deutsch, der Buddyadmin auf Englisch. Die entsprechenden Labels sind in der XML vorhanden; den Punkt hatte ich bereits geprüft.

    Grüße,
    Sebastian

  4. Hallo Sebastian,
    hast du denn ein Release für die Extension für Typo3 6.x geplant?
    Viele Grüße
    Dani

  5. Hallo Jens
    ich habe jetzt zum ersten mal CWT Community installiert. Hat soweit auch gut geklappt. Es wäre auch genau das richtige für meine Website. Nur bekomme ich zwei Dinge nicht zum laufen:

    1. User Profil View produziert folgenden Typo3 Fehler:

    Oops, an error occured!

    Syntax error in template “…../typo3conf/ext/cwt_community/pi1/tx_cwtcommunity_pi1_album.html” on line 15 “{image file=$albumData[entry].preview_pic setup=plugin.tx_cwtcommunity_pi1.album.preview_photo}” – Unexpected “.”, expected one of: “}”

    2. Gallery View liefert nur die Fehlermeldung auf der Webseite:
    An unknown error has occured. Please contact your system administrator.

    Ich habe auch schon nach einer Lösung gegoogelt, aber nur Leute gefunden, die das Problem haben aber keine Lösung dafür z.b: http://www.typo3.net/forum/thematik/zeige/thema/116233/#post-create

    Eine Idee wo hier etwas falsch läuft?
    Gruß
    Martin

Leave a Reply

Your email address will not be published. Required fields are marked *